MPLS VPN互访关系控制

MPLS VPN 互访关系控制

MPLS VPN互访关系控制

1.各路由器基本信息配置
2.OSPF规范配置,修改网络类型为点对点,配置被动接口
3.MPLS骨干网运行OSPF,标签分发协议为LDP
4.RT1、RT2、RT3、RT4和RT5运行MP_IPGP,RT1为MP_IPGP RR,RT2、RT3、RT4和RT5分别与RR建立MP_IBGP邻居
5.RT4的S0/1和E3/0划分到VRF SC,S0/2、E3/1划分到VRF BG,E3/2划分到VRF HUB,RT5的S0/1和E3/0划分到VRF SC,S0/2、E3/1划分到VRF BG,E3/2划分到VRF HUB
6.RT4 VRF SC与RT6运行RIP、RT4 VRF BG 与RT7配置静态路由、RT5 VRF SC与RT8运行OSPF,RT5 VRF BG与RT9运行EBGP

IP地址分配如下:

MPLS VPN互访关系控制

RT2 E3/2 172.18.2.1/24 RT4 E3/2 172.18.4.1
RT3 E3/2 172.18.3.1/24 RT5 E3/2 172.18.5.1/24
MPLS VPN 互访关系控制如下:
1.VPN WG的站点可相互访问
2.HUB-Spoke MPLS VPN
调整WG为HUB-Spoke MPLS VPN,RT2为HUB端(中心端),RT3、RT4、RT5为Spoke端(分支端);Spoke端的WG只能访问HUB端,Spoke端间不能互访。
3.复杂MPLS VPN
调整WG的互访关系:RT2、RT3为中心端,中心端之间能够互访,RT4、RT5为分支端,分支端只能访问中心端,分支端之间不能互访。
一、MPLS 骨干网的IGP及MPLS配置略

二、MP_IPGP RR调测
RT1:
router bgp 65000
no synchronization
neighbor rrc peer-group //创建一个对等组命名rrc
neighbor rrc remote-as 65000
neighbor rrc update-source Loopback0
neighbor rrc next-hop-self
neighbor 2.2.2.2 peer-group rrc
neighbor 3.3.3.3 peer-group rrc //调用对等组rrc建立IBGP邻居
neighbor 4.4.4.4 peer-group rrc
neighbor 5.5.5.5 peer-group rrc
no auto-summary
address-family vpnv4
neighbor rrc activate //创建一个对等组命名rrc
neighbor rrc send-community extended
neighbor rrc route-reflector-client //配置成为RR的客户端
neighbor 2.2.2.2 peer-group rrc //调用对等组rrc建立MP_BGP RR
neighbor 3.3.3.3 peer-group rrc
neighbor 4.4.4.4 peer-group rrc
neighbor 5.5.5.5 peer-group rrc
exit-address-family
RT2:
router bgp 65000
no synchronization
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
RT3:
router bgp 65000
no synchronization
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
RT4:
router bgp 65000
no synchronization
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
RT5:
router bgp 65000
no synchronization
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
三、配置VRF调测
RT4:
ip vrf BG //建立VRF 命名为BG
rd 2:2 //VRF的RD为2:2
route-target export 2:20 //导出RT为2:20
route-target import 2:10 //导入RT为2:10
ip vrf SC
rd 1:1
route-target export 1:20
route-target import 1:10
RT5:
ip vrf BG
rd 2:2
route-target export 2:10
route-target import 2:20
ip vrf SC
rd 1:1
route-target export 1:10
route-target import 1:20
四、PE与CE路由协议调测
RT4:
router rip //配置CE与PE VRF之间路由协议
version 2
no auto-summary
address-family ipv4 vrf SC //配置MP_BGP
network 172.16.0.0
no auto-summary
version 2
exit-address-family
RT6:
router rip
version 2
network 6.0.0.0
network 172.16.0.0
no auto-summary
RT4:
ip route vrf BG 7.7.7.7 255.255.255.255 Serial0/2 172.17.47.2 //在VRF BG中添加静态路由
ip route vrf BG 172.17.7.0 255.255.255.0 Serial0/2 172.17.47.2
RT7:
ip route 0.0.0.0 0.0.0.0 172.17.47.1 //配置缺省路由
RT5:
router ospf 101 vrf SC //配置VRF SC OSPF
router-id 172.16.5.1
network 172.16.5.0 0.0.0.255 area 0
network 172.16.58.0 0.0.0.3 area 0
RT8:
router ospf 1
router-id 8.8.8.8
passive-interface Ethernet3/0
network 8.8.8.8 0.0.0.0 area 0
network 172.16.8.0 0.0.0.255 area 0
network 172.16.58.0 0.0.0.3 area 0
network 0.0.0.0 255.255.255.255 area 0
RT5:
router bgp 65000 //配置EBGP
address-family ipv4 vrf BG //配置MP_BGP
neighbor 172.17.59.2 remote-as 65001 //建立EBGP邻居
no auto-summary
no synchronization
exit-address-family
RT9:
router bgp 65001
no synchronization
network 9.9.9.9 mask 255.255.255.255
network 172.17.9.0 mask 255.255.255.0
network 172.17.59.0 mask 255.255.255.252
neighbor 172.17.59.1 remote-as 65000
no auto-summary
五、MPLS VPN调测
RT4:
router bgp 65000
address-family ipv4 vrf SC
redistribute connected metric 1000 //重分布直连到MP_BGP
redistribute rip metric 1000 //重RIP直连到MP_BGP
no auto-summary
no synchronization
exit-address-family
address-family ipv4 vrf BG
redistribute connected metric 1000 //重分布直连到MP_BGP
redistribute static metric 1000 //重分布静态到MP_BGP
no auto-summary
no synchronization
exit-address-family
router rip
redistribute bgp 65000 metric 5 //重分布VRF SC到RIP
RT5:
router bgp 65000
address-family ipv4 vrf SC
redistribute connected metric 1000 //重分布直连到MP_BGP
redistribute ospf 101 vrf SC metric 1000 match internal external 1 external 2 //重分布OSPF 101 VRF SC中的匹配外部5类类型1和类型2的路由到MP_BGP中
no auto-summary
no synchronization
exit-address-family
address-family ipv4 vrf BG
redistribute connected metric 1000 //重分布直连到MP_BGP
exit-address-family
六、MPLS VPN 互访关系控制
1.VPN WG的站点可相互访问
RT2、RT3、RT4、RT5配置如下:
ip vrf WG
rd 1:5
route-target export 5:5
route-target import 5:5
int e3/2
ip vrf forwarding WG
ip address 172.18.xx.1 255.255.255.0
router bgp 65000
address-family ipv4 vrf WG
redistribute connected metric 1000
no auto-summary
no synchronization
exit-address-family
测试结果:

MPLS VPN互访关系控制

注意:如果配置正确,某条路由在MP_BGP表中存在,而没有自动导入VRF,请使用clear ip route vrf 〈名字〉*
2.HUB-Spoke MPLS VPN
调整WG为HUB-Spoke MPLS VPN,RT2为HUB端(中心端),RT3、RT4、RT5为Spoke端(分支端);Spoke端的WG只能访问HUB端,Spoke端间不能互访。
RT2:RT2、RT3、RT4、RT5:
ip vrf WG
no route-target export //清除之前配置的RT
no route-target import
RT2:
ip vrf WG
route-target export 5:5
route-target import 5:10
RT3、RT4、RT5:
ip vrf WG
route-target export 5:10
route-target import 5:5
RT2(config-vrf)#do show ip route vrf WG
172.18.0.0/24 is subnetted, 4 subnets
B 172.18.4.0 [200/1000] via 4.4.4.4, 00:00:24
B 172.18.5.0 [200/1000] via 5.5.5.5, 00:02:38
C 172.18.2.0 is directly connected, Ethernet3/2
B 172.18.3.0 [200/1000] via 3.3.3.3, 00:01:54
RT3(config-vrf)#do show ip route vrf WG
172.18.0.0/24 is subnetted, 2 subnets
B 172.18.2.0 [200/1000] via 2.2.2.2, 00:01:40
C 172.18.3.0 is directly connected, Ethernet3/2
RT4(config-vrf)#do show ip route vrf WG
172.18.0.0/24 is subnetted, 2 subnets
C 172.18.4.0 is directly connected, Ethernet3/2
B 172.18.2.0 [200/1000] via 2.2.2.2, 00:00:07
注意:大家在查看VRF路由表时,还是先刷新一下VRF路由表
3.复杂MPLS VPN
调整WG的互访关系:RT2、RT3为中心端,中心端之间能够互访,RT4、RT5为分支端,分支端只能访问中心端,分支端之间不能互访。
RT2:RT2、RT3、RT4、RT5:
ip vrf WG
no route-target export //清除之前配置的RT
no route-target import
RT2、RT3:
ip vrf WG
route-target export 5:5
route-target import 5:5
route-target export 5:10
route-target import 5:20
RT4、RT5:
ip vrf WG
route-target export 5:20
route-target import 5:10
RT2:
172.18.0.0/24 is subnetted, 4 subnets
B 172.18.4.0 [200/1000] via 4.4.4.4, 00:00:03
B 172.18.5.0 [200/1000] via 5.5.5.5, 00:00:03
C 172.18.2.0 is directly connected, Ethernet3/2
B 172.18.3.0 [200/1000] via 3.3.3.3, 00:00:03
RT3:
172.18.0.0/24 is subnetted, 4 subnets
B 172.18.4.0 [200/1000] via 4.4.4.4, 00:00:09
B 172.18.5.0 [200/1000] via 5.5.5.5, 00:00:09
B 172.18.2.0 [200/1000] via 2.2.2.2, 00:00:09
C 172.18.3.0 is directly connected, Ethernet3/2
RT4:
172.18.0.0/24 is subnetted, 3 subnets
C 172.18.4.0 is directly connected, Ethernet3/2
B 172.18.2.0 [200/1000] via 2.2.2.2, 00:00:01
B 172.18.3.0 [200/1000] via 3.3.3.3, 00:00:01
RT5:
172.18.0.0/24 is subnetted, 3 subnets
C 172.18.5.0 is directly connected, Ethernet3/2
B 172.18.2.0 [200/1000] via 2.2.2.2, 00:01:02
B 172.18.3.0 [200/1000] via 3.3.3.3, 00:01:02
注意:大家在查看VRF路由表时,还是先刷新一下VRF路由表
RT的配置非常灵活,很容易实现业务分流,配置也很简单!
作者 “凡人世界”

MPLS VPN互访关系控制

分类:默认分类 时间:2012-01-06 人气:1
本文关键词:
分享到:

相关文章

  • MPLS/VPN实验:ISIS/EIGRP 2012-02-03

    MPLS/VPN实验:ISIS/EIGRP 此实验在前OSPF/STATIC的配置基础上,将配置改变,就可以作为此实验了。 需要改变的配置是CE - PE之间的协议,以及PE-P-PE之间的协议. 删除相关的静态配置以及OSPF协议. 在CE上配置EIGRP协议: router eigrp 1 network 1.1.1.1 0.0.0.0 network 192.168.1.0 0.0.0.3 no auto-summary 建立起EIGRP邻居: CE1#sh ip eigrp neighb

  • MPLS VPN故障解决办法 2012-05-16

      当主路径上的一段链路出现故障时,流量确实已经全部切换到备用路径上,但之后备用路径上也有一段链路出现故障,这时两条路径全部中断,下面就让我们看一下MPLS VPN故障中备用Tunnel路径故障导致MPLS TE Tunnel hot-standy始终不生效的故障时如何解决的   MPLS-VPN   MPLS-VPN是指采用MPLS(多协议标记转换)技术在骨干的宽带IP网络上构建企业IP专网,实现跨地域、安全、高速、可靠的数据、语音、图像多业务通信,并结合差别服务、流量工程等相关技术,将公众网

  • MPLS VPN路由传播及数据转发详解 2012-05-21

    配置就不说了,看前面的博文吧! 1.CE与PE VRF私网路由的传播 CE全局路由表中的IPV4路由,经过PE-CE间的路由协议(可以是RIP、OSPF、EIGRP、BGP等)传播到PE相应的VRF路由表中。在PE上,与CE进行路由交换的路由协议(路由协议进程或路由协议实例)都需要绑定到相应的VRF;在绑定的VRF的接口上,只能启动本VRF的路由协议;因此 ,在PE上,CE通告过来的路由信息将交给相应的VRF路由进程或路由实例处理,并将计算出来的IPV4路由加入到该进程或该实例相对应的VRF路由

  • BGP MPLS/VPN网络技术 2012-08-14

    BGP MPLS/VPN网络技术 BGP协议很早就被众人们熟知,其强大的选路策略工具能力以及其存储路由性能,超越像模像任何一种内部网关协议,从而在自治系统之间作为一部"桥"而存在. 在这之前,有EGP协议,很少有人知道它,因为它并没有广泛得到应用,现在也就不在美国的军方上用到的,但点也不多. BGP作为一种外部边界网关协议,不断的发展,现在所应用的都是BGP-4版本, 属于无类协议,前三种都是有类的,功能也没这么全.其相关的数据格式以及属性在前面提及过. MPLS技术, 来自于ATM的技术革新.

  • MPLS-VPN简介 2012-09-06

      MPLS-VPN在大型企业和运营商内部的应用非常广泛,是MPLS技术与VPN的结合。MPLS的精华在于快速标签交换,通过将查找标签列表替换传统的路由表递归查询,从而大大加速了数据包传输。在需要处理巨大数据量的运营商网络内部使用MPLS是一个理想的选择,而运营商通常需要保证客户数据的隐秘性(跨国公司有时也需要保证分公司网络之间的隔离)MPLS-VPN因运而生。   MPLS-VPN包括很多优化服务,如:路由反射器,负载均衡,环路避免,流量工程等。本文只能实现客户跨MPLS网络最简单的通信。关于

  • MPLS VPN原理进阶版 2013-09-13

    MPLS VPN是一种三层VPN.也是实施最为广泛的一种MPLS技术. 关于MPLS VPN的服务模型,这里一点带过。相信大家对MPLS VPN的架构是比较了解了: 上面就是一个MPLS VPN的核心应用模型。P和PE都运行MPLS.所以PE和P设备的选型的前提是这些设备必须要支持MPLS标签分发和转发MPLS报文的能力。 下面就MPLS VPN技术的各个技术结构做一个汇总: 虚拟路由转发VRF--virtual routing forwarding VRF是一种VPN路由和转发的实例.每一个独

  • MPLS VPN业务分流案例 2013-10-02

    MPLS VPN业务分流案例 1.各路由器基本信息配置 2.OSPF规范配置,修改网络类型为点对点,配置被动接口 3.MPLS骨干网运行OSPF,标签分发协议为LDP 4.RT4和RT5运行MP_IPGP,利用MPLS VPN实现生产与办公业务分流 5.RT4 VRF SC与RT6运行RIP、RT4 VRF BG 与RT7配置静态路由、RT5 VRF SC与RT8运行OSPF,RT5 VRF BG与RT9运行EBGP IP地址规划如下: 一.基本配置(略) 二.骨干网IGP调测 RT1: rou

  • mpls vpn的HUB-AND-SPOKE环境 2014-01-09

    mpls vpn的HUB-AND-SPOKE环境 一般企业出于安全和费用的考虑,分公司之间不互联,分公司之间的访问必须通过总公司的防火墙,既达到了安全的效果又节约了费用。 实验拓扑如下: 由于OSPF的防环机制下游比特位和域标记的存在,可能在R6的出VRF收不到路由,所以要在出VRF关闭 下游比特位和域标记。下面给出ASA 和R6的配置其余查看附件: ASA www.2cto.com interface Ethernet0/0 no nameif no security-level no ip

  • MPLS/vpn实验之,OSPF/RIPV2 2014-11-30

    MPLS/vpn实验之,OSPF/RIPV2 这个实验的配置还是从第一个实验的基础上面发展而来的,所以一些基本的配置在这里就不提了。网络拓扑如下所示:  首先完成在CE1上面的RIP配置: ,在配置此之前一定要删除以前的配置,如果不删除会出现问题的. CE1: router rip version 2 network 1.0.0.0 network 192.168.1.0 no auto-summary ! 在这上面的配置就算是完成了。 PE1: router rip version 2 net

Copyright (C) quwantang.com, All Rights Reserved.

趣玩堂 版权所有 京ICP备15002868号

processed in 0.106 (s). 10 q(s)